Creation of Hidden Launch Agent or Daemon

Identifies the creation of a hidden launch agent or daemon. An adversary may establish persistence by installing a new launch agent or daemon which executes at login.

Elastic rule (View on GitHub)

  1[metadata]
  2creation_date = "2020/01/05"
  3integration = ["endpoint"]
  4maturity = "production"
  5min_stack_comments = "New fields added: required_fields, related_integrations, setup"
  6min_stack_version = "8.3.0"
  7updated_date = "2023/11/15"
  8
  9[rule]
 10author = ["Elastic"]
 11description = """
 12Identifies the creation of a hidden launch agent or daemon. An adversary may establish persistence by installing a new
 13launch agent or daemon which executes at login.
 14"""
 15from = "now-9m"
 16index = ["logs-endpoint.events.*"]
 17language = "eql"
 18license = "Elastic License v2"
 19name = "Creation of Hidden Launch Agent or Daemon"
 20references = [
 21    "https://developer.apple.com/library/archive/documentation/MacOSX/Conceptual/BPSystemStartup/Chapters/CreatingLaunchdJobs.html",
 22]
 23risk_score = 47
 24rule_id = "092b068f-84ac-485d-8a55-7dd9e006715f"
 25setup = """## Setup
 26
 27This rule requires data coming in from Elastic Defend.
 28
 29### Elastic Defend Integration Setup
 30Elastic Defend is integrated into the Elastic Agent using Fleet. Upon configuration, the integration allows the Elastic Agent to monitor events on your host and send data to the Elastic Security app.
 31
 32#### Prerequisite Requirements:
 33- Fleet is required for Elastic Defend.
 34- To configure Fleet Server refer to the [documentation](https://www.elastic.co/guide/en/fleet/current/fleet-server.html).
 35
 36#### The following steps should be executed in order to add the Elastic Defend integration on a macOS System:
 37- Go to the Kibana home page and click "Add integrations".
 38- In the query bar, search for "Elastic Defend" and select the integration to see more details about it.
 39- Click "Add Elastic Defend".
 40- Configure the integration name and optionally add a description.
 41- Select the type of environment you want to protect, for MacOS it is recommended to select "Traditional Endpoints".
 42- Select a configuration preset. Each preset comes with different default settings for Elastic Agent, you can further customize these later by configuring the Elastic Defend integration policy. [Helper guide](https://www.elastic.co/guide/en/security/current/configure-endpoint-integration-policy.html).
 43- We suggest selecting "Complete EDR (Endpoint Detection and Response)" as a configuration setting, that provides "All events; all preventions"
 44- Enter a name for the agent policy in "New agent policy name". If other agent policies already exist, you can click the "Existing hosts" tab and select an existing policy instead.
 45For more details on Elastic Agent configuration settings, refer to the [helper guide](https://www.elastic.co/guide/en/fleet/current/agent-policy.html).
 46- Click "Save and Continue".
 47- To complete the integration, select "Add Elastic Agent to your hosts" and continue to the next section to install the Elastic Agent on your hosts.
 48For more details on Elastic Defend refer to the [helper guide](https://www.elastic.co/guide/en/security/current/install-endpoint.html).
 49"""
 50severity = "medium"
 51tags = ["Domain: Endpoint", "OS: macOS", "Use Case: Threat Detection", "Tactic: Persistence", "Tactic: Defense Evasion", "Data Source: Elastic Defend"]
 52timestamp_override = "event.ingested"
 53type = "eql"
 54
 55query = '''
 56file where host.os.type == "macos" and event.type != "deletion" and
 57  file.path :
 58  (
 59    "/System/Library/LaunchAgents/.*.plist",
 60    "/Library/LaunchAgents/.*.plist",
 61    "/Users/*/Library/LaunchAgents/.*.plist",
 62    "/System/Library/LaunchDaemons/.*.plist",
 63    "/Library/LaunchDaemons/.*.plist"
 64  )
 65'''
 66
 67
 68[[rule.threat]]
 69framework = "MITRE ATT&CK"
 70[[rule.threat.technique]]
 71id = "T1543"
 72name = "Create or Modify System Process"
 73reference = "https://attack.mitre.org/techniques/T1543/"
 74[[rule.threat.technique.subtechnique]]
 75id = "T1543.001"
 76name = "Launch Agent"
 77reference = "https://attack.mitre.org/techniques/T1543/001/"
 78
 79
 80
 81[rule.threat.tactic]
 82id = "TA0003"
 83name = "Persistence"
 84reference = "https://attack.mitre.org/tactics/TA0003/"
 85[[rule.threat]]
 86framework = "MITRE ATT&CK"
 87[[rule.threat.technique]]
 88id = "T1564"
 89name = "Hide Artifacts"
 90reference = "https://attack.mitre.org/techniques/T1564/"
 91[[rule.threat.technique.subtechnique]]
 92id = "T1564.001"
 93name = "Hidden Files and Directories"
 94reference = "https://attack.mitre.org/techniques/T1564/001/"
 95
 96
 97
 98[rule.threat.tactic]
 99id = "TA0005"
100name = "Defense Evasion"
101reference = "https://attack.mitre.org/tactics/TA0005/"

References

Related rules

to-top